EtherChannel problem with VSS (IOS 12.2(33)SXI)

I recently had an experience working on a couple of 6500-series switches in a VSS configuration.  Both switches were running IOS 12.2(33)SXI.  I found an interesting behavior when working on the switches.  I’d seen this type of behavior before on lower-end switches (Cisco/IBM CIGESM Blade Center switches), but had not seen this behavior before on the 6500-series.

While working on the switch, I started to notice some errors that were being generated, namely:

SWITCH#
*Feb  4 10:01:53.463 MST: %EC-SW1_SP-5-CANNOT_BUNDLE2: Gi1/5/2 is not compatible with Gi2/5/2 and will be suspended (trunk mode of Gi1/5/2 is dynamic, Gi2/5/2 is trunk)
SWITCH#sh run int gi1/5
*Feb  4 10:02:03.467 MST: %EC-SW1_SP-5-CANNOT_BUNDLE2: Gi1/5/2 is not compatible with Gi2/5/2 and will be suspended (trunk mode of Gi1/5/2 is dynamic, Gi2/5/2 is trunk)

Well, I had been configuring both of these switches from the ground-up, so this sparked my curiosity as I rarely (if ever) use dynamic mode for any ports.  What I found was a little disconcerting, in that the running configuration really isn’t the running configuration:

SWITCH#sh run int gi1/5/2
Building configuration…
Current configuration : 160 bytes
!
interface GigabitEthernet1/5/2
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 2 mode on
end

SWITCH#sh run int gi2/5/2
Building configuration…
Current configuration : 160 bytes
!
interface GigabitEthernet2/5/2
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 2 mode on
end

SWITCH#

Notice that both interface configurations above show a configured mode of trunk?  Yet the switch reports that one is dynamic and the other is trunk.  I tried the same thing I’ve used before on the CIGESM – re-enter the commands that are already appearing in the running configuration.

SWITCH#
*Feb  4 10:02:13.467 MST: %EC-SW1_SP-5-CANNOT_BUNDLE2: Gi1/5/2 is not compatible with Gi2/5/2 and will be suspended (trunk mode of Gi1/5/2 is dynamic, Gi2/5/2 is trunk)
SWITCH#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
SWITCH(config)#int gi1/5/2
*Feb  4 10:02:23.471 MST: %EC-SW1_SP-5-CANNOT_BUNDLE2: Gi1/5/2 is not compatible with Gi2/5/2 and will be suspended (trunk mode of Gi1/5/2 is dynamic, Gi2/5/2 is trunk)
SWITCH(config)#int gi1/5/2
SWITCH(config-if)#switch mode trunk
SWITCH(config-if)#end
SWITCH#
*Feb  4 10:02:37.343 MST: %SYS-5-CONFIG_I: Configured from console by cisco on console
SWITCH#

This is obviously a bug.  I didn’t open a TAC case about this, nor did I look at the bug toolkit, as I found a workaround.  It’ll be interesting to see if 12.2(33)SXI1 will have this fixed…

Leave a Reply

Your email address will not be published.

HTML tags are not allowed.

WordPress Themes