BGP Base Topology

The following topology is what I’m going to be using for some future BGP entries in the future.  The topology is pretty basic, however allows for the demonstration of several different Cisco IOS BGP features.


Since a picture’s worth a thousand words, here’s a diagram of the network:
BGP Base Topology

Here’s the Dynagen .net file that I created for this topology:

# Base BGP Topology for CCIEZone.com BGP scenarios
#
# set the default model
model = 3640
#
[localhost]
#
[[3640]]
image = <your image here>
ram = 128
#
[[7200]]
image = <your image here>
npe = npe-200
midplane = std
ram = 128
nvram = 128
#
[[ROUTER CE2_1]]
console = 2010
fa0/0 = PE1 fa3/0
fa1/0 = PE2 fa3/0
#
[[ROUTER PE1]]
console = 2011
model = 7200
fa0/0 = CE1_1 fa0/0
fa1/0 = CE1_2 fa1/0
fa2/0 = PE2 fa2/0
#
[[ROUTER PE2]]
console = 2012
model = 7200
fa1/0 = CE1_1 fa1/0
fa0/0 = CE1_2 fa0/0
#
[[ROUTER CE1_1]]
console = 2013
fa2/0 = CE1_2 fa2/0
fa3/0 = R1 fa0/0
#
[[ROUTER CE1_2]]
console = 2014
fa3/0 = R1 fa1/0
#
[[ROUTER R1]]
console = 2015

Here’s the base router configs for each of these routers.  Note that I’ve “trimmed” the configurations down so that only the applicable areas are shown below to save room.

CE2_1


!
hostname CE2_1
!
no ip domain lookup
!
interface Loopback0
ip address 192.168.0.10 255.255.255.255
!
interface Loopback1
ip address 10.3.1.1 255.255.255.0 secondary
ip address 10.3.2.1 255.255.255.0 secondary
ip address 10.3.3.1 255.255.255.0 secondary
ip address 10.3.4.1 255.255.255.0 secondary
ip address 10.3.5.1 255.255.255.0 secondary
ip address 10.3.0.1 255.255.255.0
!
interface FastEthernet0/0
ip address 10.1.3.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 10.1.3.6 255.255.255.252
duplex auto
speed auto
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
exec-timeout 0 0
logging synchronous
login
!

PE1


!
hostname PE1
!
no ip domain lookup
!
interface Loopback0
ip address 192.168.0.100 255.255.255.255
!
interface Loopback1
ip address 101.0.0.1 255.0.0.0 secondary
ip address 100.100.100.1 255.255.255.0
!
interface FastEthernet0/0
ip address 10.1.1.5 255.255.255.252
duplex full
!
interface FastEthernet1/0
ip address 10.1.1.9 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet2/0
ip address 10.1.1.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet3/0
ip address 10.1.3.1 255.255.255.252
duplex auto
speed auto
!
line con 0
exec-timeout 0 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
exec-timeout 0 0
logging synchronous
login
!

PE2


!
hostname PE2
!
no ip domain lookup
!
interface Loopback0
ip address 192.168.0.101 255.255.255.255
!
interface Loopback1
ip address 101.0.0.2 255.0.0.0 secondary
ip address 100.100.100.2 255.255.255.0
!
interface FastEthernet0/0
ip address 10.1.1.17 255.255.255.252
duplex full
!
interface FastEthernet1/0
ip address 10.1.1.13 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet2/0
ip address 10.1.1.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet3/0
ip address 10.1.3.5 255.255.255.252
duplex auto
speed auto
!
line con 0
exec-timeout 0 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
exec-timeout 0 0
logging synchronous
login
!

CE1_1


!
hostname CE1_1
!
no ip domain lookup
!
interface Loopback0
ip address 192.168.0.1 255.255.255.255
!
interface FastEthernet0/0
ip address 10.1.1.6 255.255.255.252
speed auto
full-duplex
!
interface FastEthernet1/0
ip address 10.1.1.10 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet2/0
ip address 10.1.2.9 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet3/0
ip address 10.1.2.1 255.255.255.252
duplex auto
speed auto
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
exec-timeout 0 0
logging synchronous
login
!

CE1_2


!
hostname CE1_2
!
no ip domain lookup
!
interface Loopback0
ip address 192.168.0.2 255.255.255.255
!
interface FastEthernet0/0
ip address 10.1.1.18 255.255.255.252
speed auto
full-duplex
!
interface FastEthernet1/0
ip address 10.1.1.14 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet2/0
ip address 10.1.2.10 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet3/0
ip address 10.1.2.5 255.255.255.252
duplex auto
speed auto
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
exec-timeout 0 0
logging synchronous
login
!

R1


!
hostname R1
!
no ip domain lookup
!
interface Loopback0
ip address 192.168.0.3 255.255.255.255
!
interface Loopback1
ip address 10.2.1.1 255.255.255.0 secondary
ip address 10.2.2.1 255.255.255.0 secondary
ip address 10.2.3.1 255.255.255.0 secondary
ip address 10.2.4.1 255.255.255.0 secondary
ip address 10.2.5.1 255.255.255.0 secondary
ip address 10.2.0.1 255.255.255.0
!
interface FastEthernet0/0
ip address 10.1.2.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 10.1.2.6 255.255.255.252
duplex auto
speed auto
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
exec-timeout 0 0
logging synchronous
login
!

Leave a Reply

Your email address will not be published.

HTML tags are not allowed.

WordPress Themes